BZOJ1008【HNOI2008】越狱 <补集转换>

Problem

【HNOI2008】越狱


Description

监狱有连续编号为 个房间,每个房间关押一个犯人,有 种宗教,每个犯人可能信仰其中一种。如果相邻房间的犯人的宗教相同,就可能发生越狱,求有多少种状态可能发生越狱。

Input

输入两个整数

Output

能越狱的状态数,答案模

Sample Input

1
2 3

Sample Output

1
6

HINT

种状态为

标签:补集转换

Solution

考虑到补集转换,这道题就是一水题。
总共有 种方案,其中不能发生越狱的有 种方案,快速幂求出,相减即可。注意处理负数。

Code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
#include <iostream>
#include <cstdio>
#define MOD 100003
using namespace std;
typedef long long lnt;
lnt PowerMod(lnt a, lnt b) {
if (b == 1) return a%MOD;
lnt ret = PowerMod(a, b/2);
return b&1 ? a%MOD*ret%MOD*ret%MOD : ret*ret%MOD;
}
int main() {
lnt m, n; scanf("%lld%lld", &m, &n);
printf("%lld", ((PowerMod(m, n)-m%MOD*PowerMod(m-1, n-1))%MOD+MOD)%MOD);
return 0;
}
------------- Thanks For Reading -------------
0%